最近新买了一个树莓派3B当玩具
下面总结一下在Mac OS X下的配置过程.
烧录系统镜像
先从https://www.raspberrypi.org/downloads/raspbian/下载img格式的镜像
将microSD卡套上卡套插入电脑
打开终端,输入
diskutil list
根据显示的磁盘号,如disk2,再输入
diskutil unmountDisk /dev/disk2
定位到img文件所在目录,输入
sudo dd bs=4m if=2016-03-18-raspbian-jessie.img of=/dev/rdisk2
稍等片刻后回到桌面手动弹出sd卡即可
menuconfig设置
执行如下命令按提示就好
sudo raspi-config
更新系统版本
依次执行
sudo apt-get -y update
sudo apt-get -y upgrade
sudo apt-get -y dist-upgrade
sudo rpi-update
中文支持
sudo apt-get -y install ttf-wqy-zenhei ttf-wqy-microhei
sudo apt-get -y install fcitx fcitx-googlepinyin fcitx-module-cloudpinyin fcitx-sunpinyin
VNC
安装tightVNC
sudo apt-get -y install tightvncserver
sudo apt-get -y install xfonts-base
配置
1.执行
vncpasswd
2.配置开机自动启动
- 首先添加启动文件
sudo nano /etc/init.d/tightvncserver
内容见这里
- 执行命令
sudo chmod +x /etc/init.d/tightvncserver
sudo update-rc.d tightvncserver defaults
重启即可
Mac连接
打开spotlight搜索screen sharing即可
地址为ip:5901
注: VNC下fcitx貌似用不了
设置网络
自动连接wifi
sudo nano /etc/wpa_supplicant/wpa_supplicant.conf
输入
country=CN
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
ssid="此处可以是中文"
psk="密码"
priority=1
}
设置静态IP
sudo nano /etc/dhcpcd.conf
最后添加
SSID 可以是中文
inform 192.168.199.200
static routers=192.168.199.1
static domain_name_servers=192.168.199.1
interface eth0
static ip_address=192.168.199.201
static routers=192.168.199.1
static domain_name_servers=192.168.199.1
192.168.199.200与192.168.199.201分别是wifi以及有线网的静态IP
一些额外的配置
安装xrdp
个人感觉比vnc要方便些
sudo apt-get install xrdp
配置exfat
现在很多U盘都采用了exfat格式,但是debian默认不支持,所以需要安装插件来支持它
sudo apt-get install exfat-fuse
待续
测试